CVE-2016-9814

NameCVE-2016-9814
DescriptionThe validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and simplesamlphp/saml2 library before 1.9.1, 1.10.x before 1.10.3, and 2.x before 2.3.3 allows remote attackers to spoof SAML responses or possibly cause a denial of service (memory consumption) by leveraging improper conversion of return values to boolean.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1298-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
simplesamlphp (PTS)stretch (security), stretch1.14.11-1+deb9u2fixed
buster1.16.3-1+deb10u2fixed
buster (security)1.16.3-1+deb10u1fixed
bullseye, sid1.18.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
simplesamlphpsourcewheezy1.9.2-1+deb7u3DLA-1298-1
simplesamlphpsource(unstable)1.14.10-1low

Notes

[jessie] - simplesamlphp <no-dsa> (Minor issue)
https://simplesamlphp.org/security/201612-01
https://github.com/simplesamlphp/saml2/pull/81
https://github.com/simplesamlphp/saml2/commit/7008b0916426212c1cc2fc238b38ab9ebff0748c
only exploitable in hard to achieve conditions
https://www.openwall.com/lists/oss-security/2016/12/03/5

Search for package or bug name: Reporting problems