CVE-2016-9839

NameCVE-2016-9839
DescriptionIn MapServer before 7.0.3, OGR driver error messages are too verbose and may leak sensitive information if data connection fails.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-734-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mapserver (PTS)jessie (security), jessie6.4.1-5+deb8u3fixed
stretch7.0.4-2fixed
buster7.2.2-1fixed
bullseye, sid7.4.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mapserversource(unstable)7.0.3-1
mapserversourcejessie6.4.1-5+deb8u1
mapserversourcewheezy6.0.1-3.2+deb7u3DLA-734-1

Notes

https://lists.osgeo.org/pipermail/mapserver-dev/2016-December/014979.html
https://github.com/mapserver/mapserver/pull/4928
https://github.com/mapserver/mapserver/pull/5356

Search for package or bug name: Reporting problems