CVE-2016-9901

NameCVE-2016-9901
DescriptionHTML tags received from the Pocket server will be processed without sanitization and any JavaScript code executed will be run in the "about:pocket-saved" (unprivileged) page, giving it access to Pocket's messaging API through HTML injection. This vulnerability affects Firefox ESR < 45.6 and Firefox < 50.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-743-1, DSA-3734-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid69.0-1fixed
firefox-esr (PTS)jessie52.8.1esr-1~deb8u1fixed
jessie (security)60.9.0esr-1~deb8u1fixed
stretch60.7.1esr-1~deb9u1fixed
stretch (security)60.9.0esr-1~deb9u1fixed
buster60.8.0esr-1~deb10u1fixed
buster (security)60.9.0esr-1~deb10u1fixed
bullseye60.8.0esr-1fixed
sid68.1.0esr-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)50.1.0-1high
firefox-esrsource(unstable)45.6.0esr-1high
firefox-esrsourcejessie45.6.0esr-1~deb8u1highDSA-3734-1
firefox-esrsourcewheezy45.6.0esr-1~deb7u1highDLA-743-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2016-95/#CVE-2016-9901

Search for package or bug name: Reporting problems