CVE-2016-9935

NameCVE-2016-9935
DescriptionThe php_wddx_push_element function in ext/wddx/wddx.c in PHP before 5.6.29 and 7.x before 7.0.14 allows remote attackers to cause a denial of service (out-of-bounds read and memory corruption) or possibly have unspecified other impact via an empty boolean element in a wddxPacket XML document.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-818-1, DSA-3737-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)wheezy5.4.45-0+deb7u2vulnerable
wheezy (security)5.4.45-0+deb7u11fixed
jessie (security), jessie5.6.30+dfsg-0+deb8u1fixed
php7.0 (PTS)stretch7.0.19-1fixed
buster, sid7.0.22-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)(unfixed)high
php5sourcejessie5.6.29+dfsg-0+deb8u1highDSA-3737-1
php5sourcewheezy5.4.45-0+deb7u7highDLA-818-1
php7.0source(unstable)7.0.14-1high

Notes

Fixed in PHP 5.6.29 and 7.0.14
PHP Bug: https://bugs.php.net/bug.php?id=73631
Fixed by: https://github.com/php/php-src/commit/66fd44209d5ffcb9b3d1bc1b9fd8e35b485040c0
http://www.openwall.com/lists/oss-security/2016/12/12/2

Search for package or bug name: Reporting problems