CVE-2016-9954

NameCVE-2016-9954
DescriptionThe backtrack compilation code in the Irregex package (aka IrRegular Expressions) before 0.9.6 for Scheme allows remote attackers to cause a denial of service (memory consumption) via a crafted regular expression with a repeating pattern.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs851278

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chicken (PTS)wheezy4.7.0-1vulnerable
wheezy (security)4.7.0-1+deb7u2vulnerable
jessie4.9.0.1-1vulnerable
buster, stretch4.11.0-1vulnerable
sid4.12.0-0.3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chickensource(unstable)4.12.0-0.2low851278

Notes

[stretch] - chicken <no-dsa> (Minor issue)
[jessie] - chicken <no-dsa> (Minor issue)
[wheezy] - chicken <no-dsa> (Minor issue)
http://www.openwall.com/lists/oss-security/2016/12/14/18
https://github.com/ashinn/irregex/commit/a16ffc86eca15fca9e40607d41de3cea9cf868f1
For chicken vulnerable code in ./irregex-core.scm

Search for package or bug name: Reporting problems