CVE-2016-9963

NameCVE-2016-9963
DescriptionExim before 4.87.1 might allow remote attackers to obtain the private DKIM signing key via vectors related to log files and bounce messages.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-762-1, DSA-3747-1
NVD severitylow (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
exim4 (PTS)wheezy4.80-7+deb7u3vulnerable
wheezy (security)4.80-7+deb7u5fixed
jessie (security), jessie4.84.2-2+deb8u4fixed
stretch (security), stretch4.89-2+deb9u2fixed
buster4.90~RC3-2fixed
sid4.90~RC4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
exim4source(unstable)4.88~RC6-2low
exim4sourcejessie4.84.2-2+deb8u2lowDSA-3747-1
exim4sourcewheezy4.80-7+deb7u4lowDLA-762-1

Notes

https://bugs.exim.org/show_bug.cgi?id=1996
http://www.openwall.com/lists/oss-security/2016/12/16/1
https://exim.org/static/doc/CVE-2016-9963.txt

Search for package or bug name: Reporting problems