CVE-2016-9969

NameCVE-2016-9969
DescriptionIn libwebp 0.5.1, there is a double free bug in libwebpmux.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libwebp (PTS)jessie0.4.1-1.2fixed
stretch0.5.2-1fixed
bullseye, sid, buster0.6.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libwebpsource(unstable)0.5.2-1medium
libwebpsourcejessie(not affected)

Notes

[jessie] - libwebp <not-affected> (Vulnerable code not present; introduced later)
https://bugs.chromium.org/p/webp/issues/detail?id=322
https://chromium.googlesource.com/webm/libwebp/+/5ab6d9de1fb690dc20a27e5120e4d976b96502aa

Search for package or bug name: Reporting problems