CVE-2017-0356

NameCVE-2017-0356
DescriptionA flaw, similar to to CVE-2016-9646, exists in ikiwiki before 3.20170111, in the passwordauth plugin's use of CGI::FormBuilder, allowing an attacker to bypass authentication via repeated parameters.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-812-1, DSA-3760-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ikiwiki (PTS)wheezy3.20120629.2vulnerable
wheezy (security)3.20120629.2+deb7u2fixed
jessie (security), jessie3.20141016.4fixed
stretch3.20170111fixed
buster, sid3.20180311-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ikiwikisource(unstable)3.20170111high
ikiwikisourcejessie3.20141016.4highDSA-3760-1
ikiwikisourcewheezy3.20120629.2+deb7u2highDLA-812-1

Notes

https://ikiwiki.info/security/#cve-2017-0356

Search for package or bug name: Reporting problems