CVE-2017-0357

NameCVE-2017-0357
DescriptionA heap-overflow flaw exists in the -tr loader of iucode-tool starting with v1.4 and before v2.1.1, potentially leading to SIGSEGV, or heap corruption.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
iucode-tool (PTS)wheezy/contrib0.8.3-2fixed
jessie/contrib1.1.1-1fixed
stretch/contrib2.1.1-1fixed
buster/contrib, sid/contrib2.3.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iucode-toolsource(unstable)2.1.1-1
iucode-toolsourcejessie(not affected)
iucode-toolsourcewheezy(not affected)

Notes

[jessie] - iucode-tool <not-affected> (Vulnerable code not present)
[wheezy] - iucode-tool <not-affected> (Vulnerable code not present)
https://gitlab.com/iucode-tool/iucode-tool/issues/3

Search for package or bug name: Reporting problems