DescriptionA heap-overflow flaw exists in the -tr loader of iucode-tool starting with v1.4 and before v2.1.1, potentially leading to SIGSEGV, or heap corruption.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
iucode-tool (PTS)sid/contrib, bookworm/contrib, buster/contrib, bullseye/contrib2.3.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iucode-toolsourcewheezy(not affected)
iucode-toolsourcejessie(not affected)


[jessie] - iucode-tool <not-affected> (Vulnerable code not present)
[wheezy] - iucode-tool <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems