CVE-2017-0373

NameCVE-2017-0373
DescriptionThe gen_class_pod implementation in lib/Config/Model/Utils/GenClassPod.pm in Config-Model (aka libconfig-model-perl) before 2.102 has a dangerous "use lib" line, which allows remote attackers to have an unspecified impact via a crafted Debian package file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libconfig-model-perl (PTS)wheezy2.021-3+deb7u1fixed
jessie2.061-1vulnerable
stretch2.097-2fixed
buster, sid2.113-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libconfig-model-perlsource(unstable)2.097-2medium
libconfig-model-perlsourcewheezy(not affected)

Notes

[jessie] - libconfig-model-perl <no-dsa> (Minor issue)
[wheezy] - libconfig-model-perl <not-affected> (Vulnerable code do not exist)
https://anonscm.debian.org/cgit/pkg-perl/packages/libconfig-model-perl.git/commit/?h=stretch&id=e7e5dd1a650939a0e021d1d5b311dbb3c4884773

Search for package or bug name: Reporting problems