DescriptionThe gen_class_pod implementation in lib/Config/Model/Utils/ in Config-Model (aka libconfig-model-perl) before 2.102 has a dangerous "use lib" line, which allows remote attackers to have an unspecified impact via a crafted Debian package file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libconfig-model-perl (PTS)buster2.133-1fixed
bookworm, sid2.152-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libconfig-model-perlsourcewheezy(not affected)


[jessie] - libconfig-model-perl <no-dsa> (Minor issue)
[wheezy] - libconfig-model-perl <not-affected> (Vulnerable code do not exist)

Search for package or bug name: Reporting problems