CVE-2017-0381

NameCVE-2017-0381
DescriptionAn information disclosure vulnerability in silk/NLSF_stabilize.c in libopus in Mediaserver could enable a local malicious application to access data outside of its permission levels. This issue is rated as Moderate because it could be used to access sensitive data without permission. Product: Android. Versions: 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1. Android ID: A-31607432.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-793-1
NVD severityhigh
Debian Bugs851612

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
opus (PTS)stretch1.2~alpha2-1fixed
buster1.3-1fixed
bookworm, sid, bullseye1.3.1-0.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opussourcewheezy0.9.14+20120615-1+nmu1+deb7u1DLA-793-1
opussource(unstable)1.2~alpha2-1851612

Notes

[jessie] - opus <ignored> (Minor issue, https://bugs.debian.org/851612#10)
Fixed by: https://github.com/xiph/opus/commit/79e8f527b0344b0897a65be35e77f7885bd99409 (v1.2-alpha)
https://github.com/xiph/opus/commit/70a3d641b760b3d313b6025f82aed93a460720e5

Search for package or bug name: Reporting problems