CVE-2017-0561

NameCVE-2017-0561
DescriptionA remote code execution vulnerability in the Broadcom Wi-Fi firmware could enable a remote attacker to execute arbitrary code within the context of the Wi-Fi SoC. This issue is rated as Critical due to the possibility of remote code execution in the context of the Wi-Fi SoC. Product: Android. Versions: Kernel-3.10, Kernel-3.18. Android ID: A-34199105. References: B-RB#110814.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1573-1
NVD severityhigh (attack range: remote)
Debian Bugs869639

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firmware-nonfree (PTS)jessie/non-free0.43vulnerable
stretch/non-free20161130-4fixed
sid/non-free, buster/non-free20180825+dfsg-1fixed
jessie/non-free (security)20161130-4~deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firmware-nonfreesource(unstable)20180518-1high869639
firmware-nonfreesourcejessie20161130-4~deb8u1highDLA-1573-1
firmware-nonfreesourcestretch20161130-4high

Notes

[jessie] - firmware-nonfree <no-dsa> (non-free not supported)

Search for package or bug name: Reporting problems