CVE-2017-1000115

NameCVE-2017-1000115
DescriptionMercurial prior to version 4.3 is vulnerable to a missing symlink check that can malicious repositories to modify files outside the repository
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1072-1, DSA-3963-1
NVD severitymedium
Debian Bugs871709

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mercurial (PTS)stretch4.0-1+deb9u1fixed
stretch (security)4.0-1+deb9u2fixed
buster4.8.2-1+deb10u1fixed
bullseye, sid5.6.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mercurialsourcewheezy2.2.2-4+deb7u5DLA-1072-1
mercurialsourcejessie3.1.2-2+deb8u4DSA-3963-1
mercurialsourcestretch4.0-1+deb9u1DSA-3963-1
mercurialsource(unstable)4.3.1-1871709

Notes

https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_4.3_.282017-08-10.29
https://www.mercurial-scm.org/repo/hg/rev/47ea28293d30 (test)
https://www.mercurial-scm.org/repo/hg/rev/377e8ddaebef (fix)
3.7 and 4.1 backports available at https://bitbucket.org/atlassian/mercurial/commits/branch/sec-3.7
and https://bitbucket.org/octobus/mercurial-backport/branch/backport-4.1CVE-2017-12777

Search for package or bug name: Reporting problems