CVE-2017-1000127

NameCVE-2017-1000127
DescriptionExiv2 0.26 contains a heap buffer overflow in tiff parser
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs888863

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
exiv2 (PTS)wheezy0.23-1fixed
wheezy (security)0.23-1+deb7u2fixed
jessie0.24-4.1fixed
buster, sid, stretch0.25-3.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
exiv2source(unstable)(not affected)
exiv2sourceexperimental(unfixed)low888863

Notes

- exiv2 <not-affected> (Vulnerable code introduced after 0.25)
http://www.openwall.com/lists/oss-security/2017/06/30/1
https://github.com/Exiv2/exiv2/issues/176

Search for package or bug name: Reporting problems