CVE-2017-1000250

NameCVE-2017-1000250
DescriptionAll versions of the SDP server in BlueZ 5.46 and earlier are vulnerable to an information disclosure vulnerability which allows remote attackers to obtain sensitive information from the bluetoothd process memory. This vulnerability lies in the processing of SDP search attribute requests.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1103-1, DSA-3972-1
NVD severitylow (attack range: remote)
Debian Bugs875633

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
bluez (PTS)wheezy4.99-2vulnerable
wheezy (security)4.99-2+deb7u1fixed
jessie5.23-2vulnerable
jessie (security)5.23-2+deb8u1fixed
stretch (security), stretch5.43-2+deb9u1fixed
buster, sid5.47-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
bluezsource(unstable)5.46-1low875633
bluezsourcejessie5.23-2+deb8u1lowDSA-3972-1
bluezsourcestretch5.43-2+deb9u1lowDSA-3972-1
bluezsourcewheezy4.99-2+deb7u1lowDLA-1103-1

Notes

https://www.armis.com/blueborne/
https://git.kernel.org/pub/scm/bluetooth/bluez.git/commit/?id=9e009647b14e810e06626dde7f1bb9ea3c375d09

Search for package or bug name: Reporting problems