CVE-2017-1000256

NameCVE-2017-1000256
Descriptionlibvirt version 2.3.0 and later is vulnerable to a bad default configuration of "verify-peer=no" passed to QEMU by libvirt resulting in a failure to validate SSL/TLS certificates by default.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4003-1
NVD severitymedium (attack range: remote)
Debian Bugs878799

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvirt (PTS)jessie (security), jessie1.2.9-9+deb8u5fixed
stretch (security), stretch3.0.0-4+deb9u3fixed
buster, sid4.7.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvirtsource(unstable)3.8.0-3medium878799
libvirtsourcejessie(not affected)
libvirtsourcestretch3.0.0-4+deb9u1mediumDSA-4003-1
libvirtsourcewheezy(not affected)

Notes

[jessie] - libvirt <not-affected> (Vulnerable code introduced later)
[wheezy] - libvirt <not-affected> (Vulnerable code introduced later)
https://www.redhat.com/archives/libvirt-announce/2017-October/msg00001.html
https://security.libvirt.org/2017/0002.html
Broken by: http://libvirt.org/git/?p=libvirt.git;a=commit;h=ce61c16450d4992612d1fc6f39a39e79bfccead5 (master)
Fixed by: http://libvirt.org/git/?p=libvirt.git;a=commit;h=441d3eb6d1be940a67ce45a286602a967601b157 (master)

Search for package or bug name: Reporting problems