Descriptionlibvirt version 2.3.0 and later is vulnerable to a bad default configuration of "verify-peer=no" passed to QEMU by libvirt resulting in a failure to validate SSL/TLS certificates by default.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs878799

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvirt (PTS)jessie (security), jessie1.2.9-9+deb8u5fixed
stretch (security), stretch3.0.0-4+deb9u3fixed
buster, sid5.0.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvirtsourcejessie(not affected)
libvirtsourcewheezy(not affected)


[jessie] - libvirt <not-affected> (Vulnerable code introduced later)
[wheezy] - libvirt <not-affected> (Vulnerable code introduced later)
Broken by:;a=commit;h=ce61c16450d4992612d1fc6f39a39e79bfccead5 (master)
Fixed by:;a=commit;h=441d3eb6d1be940a67ce45a286602a967601b157 (master)

Search for package or bug name: Reporting problems