CVE-2017-1000366

NameCVE-2017-1000366
Descriptionglibc contains a vulnerability that allows specially crafted LD_LIBRARY_PATH values to manipulate the heap/stack, causing them to alias, potentially resulting in arbitrary code execution. Please note that additional hardening changes have been made to glibc to prevent manipulation of stack and heap memory but these issues are not directly exploitable, as such they have not been given a CVE. This affects glibc 2.25 and earlier.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-992-1, DSA-3887-1
NVD severityhigh (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
eglibc (PTS)wheezy2.13-38+deb7u10vulnerable
wheezy (security)2.13-38+deb7u12fixed
glibc (PTS)jessie (security), jessie2.19-18+deb8u10fixed
stretch (security), stretch2.24-11+deb9u1fixed
buster2.24-12fixed
sid2.24-14fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
eglibcsource(unstable)(unfixed)high
eglibcsourcewheezy2.13-38+deb7u12highDLA-992-1
glibcsource(unstable)2.24-12high
glibcsourcejessie2.19-18+deb8u10highDSA-3887-1
glibcsourcestretch2.24-11+deb9u1highDSA-3887-1

Notes

https://www.qualys.com/2017/06/19/stack-clash/stack-clash.txt

Search for package or bug name: Reporting problems