|Description||glibc contains a vulnerability that allows specially crafted LD_LIBRARY_PATH values to manipulate the heap/stack, causing them to alias, potentially resulting in arbitrary code execution. Please note that additional hardening changes have been made to glibc to prevent manipulation of stack and heap memory but these issues are not directly exploitable, as such they have not been given a CVE. This affects glibc 2.25 and earlier.|
|Source||CVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)|
|NVD severity||high (attack range: local)|
Vulnerable and fixed packages
The table below lists information on source packages.
|glibc (PTS)||jessie (security), jessie||2.19-18+deb8u10||fixed|
|stretch (security), stretch||2.24-11+deb9u1||fixed|
The information below is based on the following data on fixed versions.