CVE-2017-1000367

NameCVE-2017-1000367
DescriptionTodd Miller's sudo version 1.8.20 and earlier is vulnerable to an input validation (embedded spaces) in the get_process_ttyname() function resulting in information disclosure and command execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-970-1, DSA-3867-1
NVD severitymedium (attack range: local)
Debian Bugs863731

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sudo (PTS)wheezy1.8.5p2-1+nmu3+deb7u1vulnerable
wheezy (security)1.8.5p2-1+nmu3+deb7u4fixed
jessie (security), jessie1.8.10p3-1+deb8u4fixed
stretch1.8.19p1-2.1fixed
buster, sid1.8.20p2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sudosource(unstable)1.8.20p1-1medium863731
sudosourcebuster1.8.19p1-2medium
sudosourcejessie1.8.10p3-1+deb8u4mediumDSA-3867-1
sudosourcestretch1.8.19p1-2medium
sudosourcewheezy1.8.5p2-1+nmu3+deb7u3mediumDLA-970-1

Notes

https://www.sudo.ws/alerts/linux_tty.html
http://www.openwall.com/lists/oss-security/2017/05/30/16
https://www.sudo.ws/repos/sudo/raw-rev/b5460cbbb11b

Search for package or bug name: Reporting problems