CVE-2017-1000379

NameCVE-2017-1000379
DescriptionThe Linux Kernel running on AMD64 systems will sometimes map the contents of PIE executable, the heap or ld.so to where the stack is mapped allowing attackers to more easily manipulate the stack. Linux Kernel version 4.11.5 is affected.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)wheezy3.2.78-1vulnerable
wheezy (security)3.2.93-1vulnerable
jessie3.16.43-2+deb8u2vulnerable
jessie (security)3.16.43-2+deb8u5vulnerable
stretch4.9.51-1vulnerable
stretch (security)4.9.30-2+deb9u5vulnerable
buster, sid4.13.13-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)(unfixed)high

Notes

https://www.qualys.com/2017/06/19/stack-clash/stack-clash.txt

Search for package or bug name: Reporting problems