CVE-2017-1000418

NameCVE-2017-1000418
DescriptionThe WildMidi_Open function in WildMIDI since commit d8a466829c67cacbb1700beded25c448d99514e5 allows remote attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly have unspecified other impact via a crafted file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs886503

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wildmidi (PTS)wheezy0.2.3.4-2.1fixed
jessie0.3.7-1fixed
stretch0.4.0-2vulnerable
buster, sid0.4.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wildmidisource(unstable)0.4.2-1886503
wildmidisourcejessie(not affected)
wildmidisourcewheezy(not affected)

Notes

[stretch] - wildmidi <no-dsa> (Minor issue)
[jessie] - wildmidi <not-affected> (Vulnerable code introduced later)
[wheezy] - wildmidi <not-affected> (Vulnerable code introduced later)
https://github.com/Mindwerks/wildmidi/issues/178
https://github.com/Mindwerks/wildmidi/commit/814f31d8eceda8401eb812fc2e94ed143fdad0ab

Search for package or bug name: Reporting problems