CVE-2017-1000422

NameCVE-2017-1000422
DescriptionGnome gdk-pixbuf 2.36.8 and older is vulnerable to several integer overflow in the gif_get_lzw function resulting in memory corruption and potential code execution
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1234-1, DSA-4088-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gdk-pixbuf (PTS)jessie (security), jessie2.31.1-2+deb8u7fixed
stretch (security), stretch2.36.5-2+deb9u2fixed
buster, sid2.38.0+dfsg-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gdk-pixbufsource(unstable)2.36.11-1medium
gdk-pixbufsourcejessie2.31.1-2+deb8u7mediumDSA-4088-1
gdk-pixbufsourcestretch2.36.5-2+deb9u2mediumDSA-4088-1
gdk-pixbufsourcewheezy2.26.1-1+deb7u7mediumDLA-1234-1

Notes

https://bugzilla.gnome.org/show_bug.cgi?id=785973
Fixed by: https://git.gnome.org/browse/gdk-pixbuf/commit/?id=0012e066ba37439d402ce46afbc1311530a4ec61

Search for package or bug name: Reporting problems