CVE-2017-1000430

NameCVE-2017-1000430
Descriptionrust-base64 version <= 0.5.1 is vulnerable to a buffer overflow when calculating the size of a buffer to use when encoding base64 using the 'encode_config_buf' and 'encode_config' functions
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Notes

NOT-FOR-US: rust-base64
https://github.com/RustSec/advisory-db/blob/master/crates/base64/RUSTSEC-2017-0004.toml

Search for package or bug name: Reporting problems