CVE-2017-1000480

NameCVE-2017-1000480
DescriptionSmarty 3 before 3.1.32 is vulnerable to a PHP code injection when calling fetch() or display() functions on custom resources that does not sanitize template name.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1249-1, DSA-4094-1
NVD severityhigh (attack range: remote)
Debian Bugs886460

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
smarty3 (PTS)jessie (security), jessie3.1.21-1+deb8u2fixed
stretch (security), stretch3.1.31+20161214.1.c7d42e4+selfpack1-2+deb9u1fixed
buster, sid3.1.32+20180424.1.ac9d4b58+selfpack1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
smartysource(unstable)(unfixed)high
smarty3source(unstable)3.1.31+20161214.1.c7d42e4+selfpack1-3high886460
smarty3sourcejessie3.1.21-1+deb8u1highDSA-4094-1
smarty3sourcestretch3.1.31+20161214.1.c7d42e4+selfpack1-2+deb9u1highDSA-4094-1
smarty3sourcewheezy3.1.10-2+deb7u2highDLA-1249-1

Notes

https://github.com/smarty-php/smarty/commit/614ad1f8b9b00086efc123e49b7bb8efbfa81b61

Search for package or bug name: Reporting problems