CVE-2017-1000501

NameCVE-2017-1000501
DescriptionAwstats version 7.6 and earlier is vulnerable to a path traversal flaw in the handling of the "config" and "migrate" parameters resulting in unauthenticated remote code execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1238-1, DSA-4092-1
NVD severityhigh (attack range: remote)
Debian Bugs885835

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
awstats (PTS)wheezy7.0~dfsg-7vulnerable
wheezy (security)7.0~dfsg-7+deb7u1fixed
jessie7.2+dfsg-1vulnerable
jessie (security)7.2+dfsg-1+deb8u1fixed
stretch (security), stretch7.6+dfsg-1+deb9u1fixed
buster, sid7.6+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
awstatssource(unstable)7.6+dfsg-2high885835
awstatssourcejessie7.2+dfsg-1+deb8u1highDSA-4092-1
awstatssourcestretch7.6+dfsg-1+deb9u1highDSA-4092-1
awstatssourcewheezy7.0~dfsg-7+deb7u1highDLA-1238-1

Notes

https://github.com/eldy/awstats/commit/cf219843a74c951bf5986f3a7fffa3dcf99c3899
https://github.com/eldy/awstats/commit/06c0ab29c1e5059d9e0279c6b64d573d619e1651

Search for package or bug name: Reporting problems