CVE-2017-1000600

NameCVE-2017-1000600
DescriptionWordPress version <4.9 contains a CWE-20 Input Validation vulnerability in thumbnail processing that can result in remote code execution. This attack appears to be exploitable via thumbnail upload by an authenticated user and may require additional plugins in order to be exploited however this has not been confirmed at this time. This issue appears to have been partially, but not completely fixed in WordPress 4.9
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)jessie4.1+dfsg-1+deb8u17vulnerable
jessie (security)4.1.28+dfsg-0+deb8u1vulnerable
stretch (security), stretch4.7.5+dfsg-2+deb9u5vulnerable
buster5.0.4+dfsg1-1fixed
bullseye, sid5.2.4+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)4.9.1+dfsg-1

Notes

https://www.securityfocus.com/bid/105305/references
https://www.theregister.co.uk/2018/08/20/php_unserialisation_wordpress_vuln/
https://cdn2.hubspot.net/hubfs/3853213/us-18-Thomas-It's-A-PHP-Unserialization-Vulnerability-Jim-But-Not-As-We-....pdf
https://twitter.com/_s_n_t/status/1030573635617124353
Wordpress before 4.9 is vulnerable on its own. After 4.9 you need to have
vulnerable module installed on the site as well. Due to an incomplete fix
in 4.9 there exists CVE-2018-1000773.

Search for package or bug name: Reporting problems