DescriptionWordPress version <4.9 contains a CWE-20 Input Validation vulnerability in thumbnail processing that can result in remote code execution. This attack appears to be exploitable via thumbnail upload by an authenticated user and may require additional plugins in order to be exploited however this has not been confirmed at this time. This issue appears to have been partially, but not completely fixed in WordPress 4.9
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)jessie4.1+dfsg-1+deb8u17vulnerable
jessie (security)4.1.31+dfsg-0+deb8u1vulnerable
stretch (security)4.7.5+dfsg-2+deb9u6vulnerable
buster (security)5.0.10+dfsg1-0+deb10u1fixed
bullseye, sid5.4.2+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[jessie] - wordpress <postponed> (requires authenticated user, root cause in PHP phar:// unserialization and requires thorough application-level checks, no upstream patch)'s-A-PHP-Unserialization-Vulnerability-Jim-But-Not-As-We-....pdf (possible mitigation) (75-76, pre-4.9 POP chain) (4.9 POP chain break)
Wordpress before 4.9 is vulnerable on its own. After 4.9 you need to have
vulnerable module installed on the site as well. Due to an incomplete fix
in 4.9 there exists CVE-2018-1000773.

Search for package or bug name: Reporting problems