CVE-2017-10683

NameCVE-2017-10683
DescriptionIn mpg123 1.25.0, there is a heap-based buffer over-read in the convert_latin1 function in libmpg123/id3.c. A crafted input will lead to a remote denial of service attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1017-1
NVD severitymedium
Debian Bugs866860

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mpg123 (PTS)jessie1.20.1-2+deb8u1vulnerable
stretch1.23.8-1vulnerable
buster1.25.10-2fixed
bullseye, sid1.25.13-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mpg123source(unstable)1.25.1-1866860
mpg123sourcewheezy1.14.4-1+deb7u2DLA-1017-1

Notes

[stretch] - mpg123 <no-dsa> (Minor issue)
[jessie] - mpg123 <no-dsa> (Minor issue)
https://bugzilla.redhat.com/show_bug.cgi?id=1465819
Duplicate of https://sourceforge.net/p/mpg123/bugs/252/
Patch: http://scm.orgis.org/view/mpg123/trunk/src/libmpg123/id3.c?sortby=date&r1=4249&r2=4248&pathrev=4249

Search for package or bug name: Reporting problems