CVE-2017-10687

NameCVE-2017-10687
DescriptionIn LibSass 3.4.5, there is a heap-based buffer over-read in the function json_mkstream() in sass_context.cpp. A crafted input will lead to a remote denial of service attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs866672

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libsass (PTS)buster, sid, stretch3.4.3-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsasssource(unstable)(unfixed)low866672

Notes

[stretch] - libsass <no-dsa> (Minor issue)
https://bugzilla.redhat.com/show_bug.cgi?id=1466411

Search for package or bug name: Reporting problems