CVE-2017-10689

NameCVE-2017-10689
DescriptionIn previous versions of Puppet Agent it was possible to install a module with world writable permissions. Puppet Agent 5.3.4 and 1.10.10 included a fix to this vulnerability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow (attack range: local)
Debian Bugs890412

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
puppet (PTS)jessie (security), jessie3.7.2-4+deb8u1vulnerable
stretch4.8.2-5vulnerable
buster, sid5.5.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
puppetsource(unstable)5.4.0-1low890412
puppetsourcewheezy(not affected)

Notes

[stretch] - puppet <no-dsa> (Minor issue)
[jessie] - puppet <no-dsa> (Minor issue)
[wheezy] - puppet <not-affected> (vulnerable code not present)
https://puppet.com/security/cve/CVE-2017-10689
https://tickets.puppetlabs.com/browse/PUP-7866
https://github.com/puppetlabs/puppet/commit/17d9e02da3882e44c1876e2805cf9708481715ee
https://github.com/puppetlabs/puppet/commit/983154f7e29a2a50d416d889a6fed012b9b12399

Search for package or bug name: Reporting problems