CVE-2017-10788

NameCVE-2017-10788
DescriptionThe DBD::mysql module through 4.043 for Perl allows remote attackers to cause a denial of service (use-after-free and application crash) or possibly have unspecified other impact by triggering (1) certain error responses from a MySQL server or (2) a loss of a network connection to a MySQL server. The use-after-free defect was introduced by relying on incorrect Oracle mysql_stmt_close documentation and code examples.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1079-1
NVD severityhigh (attack range: remote)
Debian Bugs866818

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libdbd-mysql-perl (PTS)wheezy4.021-1vulnerable
wheezy (security)4.021-1+deb7u3fixed
jessie (security), jessie4.028-2+deb8u2vulnerable
buster, sid, stretch4.041-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libdbd-mysql-perlsource(unstable)(unfixed)high866818
libdbd-mysql-perlsourcewheezy4.021-1+deb7u3highDLA-1079-1

Notes

[stretch] - libdbd-mysql-perl <no-dsa> (Minor issue, can be fixed via point release)
[jessie] - libdbd-mysql-perl <no-dsa> (Minor issue, can be fixed via point release)
http://seclists.org/oss-sec/2017/q2/443
https://github.com/perl5-dbi/DBD-mysql/issues/120
https://github.com/perl5-dbi/DBD-mysql/pull/142

Search for package or bug name: Reporting problems