CVE-2017-10789

NameCVE-2017-10789
DescriptionThe DBD::mysql module through 4.043 for Perl uses the mysql_ssl=1 setting to mean that SSL is optional (even though this setting's documentation has a "your communication with the server will be encrypted" statement), which allows man-in-the-middle attackers to spoof servers via a cleartext-downgrade attack, a related issue to CVE-2015-3152.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs866821

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libdbd-mysql-perl (PTS)wheezy4.021-1vulnerable
wheezy (security)4.021-1+deb7u2vulnerable
jessie (security), jessie4.028-2+deb8u2vulnerable
buster, sid, stretch4.041-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libdbd-mysql-perlsource(unstable)(unfixed)medium866821

Notes

https://github.com/perl5-dbi/DBD-mysql/issues/110
https://github.com/perl5-dbi/DBD-mysql/pull/114

Search for package or bug name: Reporting problems