CVE-2017-10912

NameCVE-2017-10912
DescriptionXen through 4.8.x mishandles page transfer, which allows guest OS users to obtain privileged host OS access, aka XSA-217.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1132-1, DSA-3969-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)wheezy4.1.4-3+deb7u9vulnerable
wheezy (security)4.1.6.lts1-12fixed
jessie (security), jessie4.4.1-9+deb8u10fixed
buster, sid, stretch4.8.2+xsa245-0+deb9u1fixed
stretch (security)4.8.3+comet2+shim4.10.0+comet3-1+deb9u4.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensource(unstable)4.8.1-1+deb9u3high
xensourcejessie4.4.1-9+deb8u10highDSA-3969-1
xensourcestretch4.8.1-1+deb9u3highDSA-3969-1
xensourcewheezy4.1.6.lts1-9highDLA-1132-1

Notes

https://xenbits.xen.org/xsa/advisory-217.html

Search for package or bug name: Reporting problems