CVE-2017-10913

NameCVE-2017-10913
DescriptionThe grant-table feature in Xen through 4.8.x provides false mapping information in certain cases of concurrent unmap calls, which allows backend attackers to obtain sensitive information or gain privileges, aka XSA-218 bug 1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3969-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)wheezy4.1.4-3+deb7u9vulnerable
wheezy (security)4.1.6.lts1-8vulnerable
jessie4.4.1-9+deb8u9vulnerable
jessie (security)4.4.1-9+deb8u10fixed
buster, sid, stretch4.8.1-1+deb9u1vulnerable
stretch (security)4.8.1-1+deb9u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensource(unstable)(unfixed)high
xensourcejessie4.4.1-9+deb8u10highDSA-3969-1
xensourcestretch4.8.1-1+deb9u3highDSA-3969-1

Notes

https://xenbits.xen.org/xsa/advisory-218.html

Search for package or bug name: Reporting problems