CVE-2017-10916

NameCVE-2017-10916
DescriptionThe vCPU context-switch implementation in Xen through 4.8.x improperly interacts with the Memory Protection Extensions (MPX) and Protection Key (PKU) features, which makes it easier for guest OS users to defeat ASLR and other protection mechanisms, aka XSA-220.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)wheezy4.1.4-3+deb7u9fixed
wheezy (security)4.1.6.lts1-10fixed
jessie4.4.1-9+deb8u9fixed
jessie (security)4.4.1-9+deb8u10fixed
buster, sid, stretch (security), stretch4.8.1-1+deb9u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensource(unstable)4.8.1-1+deb9u3medium
xensourcejessie(not affected)
xensourcestretch4.8.1-1+deb9u3medium
xensourcewheezy(not affected)

Notes

[jessie] - xen <not-affected> (Vulnerable code not present)
[wheezy] - xen <not-affected> (Vulnerable code not present)
https://xenbits.xen.org/xsa/advisory-220.html

Search for package or bug name: Reporting problems