CVE-2017-10919

NameCVE-2017-10919
DescriptionXen through 4.8.x mishandles virtual interrupt injection, which allows guest OS users to cause a denial of service (hypervisor crash), aka XSA-223.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)wheezy4.1.4-3+deb7u9fixed
wheezy (security)4.1.6.lts1-9fixed
jessie4.4.1-9+deb8u9vulnerable
jessie (security)4.4.1-9+deb8u10vulnerable
buster, sid, stretch (security), stretch4.8.1-1+deb9u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensource(unstable)4.8.1-1+deb9u3medium
xensourcestretch4.8.1-1+deb9u3medium
xensourcewheezy(not affected)

Notes

[jessie] - xen <ignored> (No backport available, limited to arm)
[wheezy] - xen <not-affected> (arm not supported)
https://xenbits.xen.org/xsa/advisory-223.html

Search for package or bug name: Reporting problems