CVE-2017-10923

NameCVE-2017-10923
DescriptionXen through 4.8.x does not validate a vCPU array index upon the sending of an SGI, which allows guest OS users to cause a denial of service (hypervisor crash), aka XSA-225.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)wheezy4.1.4-3+deb7u9fixed
wheezy (security)4.1.6.lts1-8fixed
jessie4.4.1-9+deb8u9fixed
jessie (security)4.4.1-9+deb8u10fixed
buster, sid, stretch4.8.1-1+deb9u1vulnerable
stretch (security)4.8.1-1+deb9u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensource(unstable)(unfixed)medium
xensourcejessie(not affected)
xensourcestretch4.8.1-1+deb9u3medium
xensourcewheezy(not affected)

Notes

[jessie] - xen <not-affected> (Vulnerable code not present)
[wheezy] - xen <not-affected> (Vulnerable code not present)
https://xenbits.xen.org/xsa/advisory-225.html

Search for package or bug name: Reporting problems