CVE-2017-10978

NameCVE-2017-10978
DescriptionAn FR-GV-201 issue in FreeRADIUS 2.x before 2.2.10 and 3.x before 3.0.15 allows "Read / write overflow in make_secret()" and a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs868765

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
freeradius (PTS)wheezy2.1.12+dfsg-1.2vulnerable
wheezy (security)2.1.12+dfsg-1.2+deb7u1vulnerable
jessie2.2.5+dfsg-0.2vulnerable
stretch3.0.12+dfsg-5vulnerable
buster, sid3.0.15+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
freeradiussource(unstable)3.0.15+dfsg-1medium868765

Notes

http://freeradius.org/security/fuzzer-2017.html#FR-GV-201
2.x: https://github.com/FreeRADIUS/freeradius-server/commit/38ee90f2a5a28dc5887a30bdfdc98109c0418e68
3.x: https://github.com/FreeRADIUS/freeradius-server/commit/fc8662d7e827f630d515eaa0bddfa94754c8047f

Search for package or bug name: Reporting problems