CVE-2017-10982

NameCVE-2017-10982
DescriptionAn FR-GV-205 issue in FreeRADIUS 2.x before 2.2.10 allows "DHCP - Buffer over-read in fr_dhcp_decode_options()" and a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1064-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
freeradius (PTS)wheezy2.1.12+dfsg-1.2vulnerable
wheezy (security)2.1.12+dfsg-1.2+deb7u2fixed
jessie2.2.5+dfsg-0.2vulnerable
jessie (security)2.2.5+dfsg-0.2+deb8u1fixed
stretch (security), stretch3.0.12+dfsg-5+deb9u1fixed
buster, sid3.0.15+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
freeradiussource(unstable)3.0.12+dfsg-3medium
freeradiussourcejessie2.2.5+dfsg-0.2+deb8u1medium
freeradiussourcewheezy2.1.12+dfsg-1.2+deb7u2mediumDLA-1064-1

Notes

http://freeradius.org/security/fuzzer-2017.html#FR-GV-205
https://github.com/FreeRADIUS/freeradius-server/commit/10b6de9345c9e0d9d4d5e0426fa5c3d68d702875
Mark as fixed in 3.0.12+dfsg-3 the first 3.x version in unstable
This is not fully technically correct, the issue affects only the 2.x
series but not 3.x.

Search for package or bug name: Reporting problems