CVE-2017-10984

NameCVE-2017-10984
DescriptionAn FR-GV-301 issue in FreeRADIUS 3.x before 3.0.15 allows "Write overflow in data2vp_wimax()" - this allows remote attackers to cause a denial of service (daemon crash) or possibly execute arbitrary code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs868765

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
freeradius (PTS)wheezy2.1.12+dfsg-1.2fixed
wheezy (security)2.1.12+dfsg-1.2+deb7u2fixed
jessie2.2.5+dfsg-0.2fixed
jessie (security)2.2.5+dfsg-0.2+deb8u1fixed
stretch3.0.12+dfsg-5vulnerable
stretch (security)3.0.12+dfsg-5+deb9u1fixed
buster, sid3.0.15+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
freeradiussource(unstable)3.0.15+dfsg-1high868765
freeradiussourcejessie(not affected)
freeradiussourcestretch3.0.12+dfsg-5+deb9u1high
freeradiussourcewheezy(not affected)

Notes

[jessie] - freeradius <not-affected> (Only affects 3.x series)
[wheezy] - freeradius <not-affected> (Only affects 3.x series)
http://freeradius.org/security/fuzzer-2017.html#FR-GV-301
https://github.com/FreeRADIUS/freeradius-server/commit/931850e5d2f65193520c2d9c9878148c0cdc16a6
https://github.com/FreeRADIUS/freeradius-server/commit/4b059296e14b6ab75dc17163077490528a819806

Search for package or bug name: Reporting problems