CVE-2017-11126

NameCVE-2017-11126
DescriptionThe III_i_stereo function in libmpg123/layer3.c in mpg123 through 1.25.1 allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted audio file that is mishandled in the code for the "block_type != 2" case, a similar issue to CVE-2017-9870.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mpg123 (PTS)wheezy1.14.4-1vulnerable
wheezy (security)1.14.4-1+deb7u2vulnerable
jessie1.20.1-2+deb8u1vulnerable
stretch1.23.8-1vulnerable
buster1.25.10-1fixed
sid1.25.10-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mpg123source(unstable)1.25.3-1unimportant

Notes

no security impact

Search for package or bug name: Reporting problems