CVE-2017-11185

NameCVE-2017-11185
DescriptionThe gmp plugin in strongSwan before 5.6.0 allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via a crafted RSA signature.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1059-1, DSA-3962-1
NVD severitymedium (attack range: remote)
Debian Bugs872155

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
strongswan (PTS)wheezy4.5.2-1.5+deb7u8vulnerable
wheezy (security)4.5.2-1.5+deb7u10fixed
jessie5.2.1-6+deb8u4vulnerable
jessie (security)5.2.1-6+deb8u5fixed
stretch (security), stretch5.5.1-4+deb9u1fixed
buster, sid5.6.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
strongswansource(unstable)5.6.0-1medium872155
strongswansourcejessie5.2.1-6+deb8u5mediumDSA-3962-1
strongswansourcestretch5.5.1-4+deb9u1mediumDSA-3962-1
strongswansourcewheezy4.5.2-1.5+deb7u10mediumDLA-1059-1

Notes

https://www.strongswan.org/blog/2017/08/14/strongswan-vulnerability-(cve-2017-11185).html
https://git.strongswan.org/?p=strongswan.git;a=commit;h=ef5c37fcdf47273feea320091598135688df4ef7

Search for package or bug name: Reporting problems