CVE-2017-11311

NameCVE-2017-11311
Descriptionsoundlib/Load_psm.cpp in OpenMPT through 1.26.12.00 and libopenmpt before 0.2.8461-beta26 has a heap buffer overflow with the potential for arbitrary code execution via a crafted PSM File that triggers use of the same sample slot for two samples.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs867579

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libopenmpt (PTS)bullseye0.4.11-1fixed
bookworm0.6.9-1fixed
sid, trixie0.7.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libopenmptsourcestretch0.2.7386~beta20.3-3+deb9u2
libopenmptsource(unstable)0.2.8461~beta26-1867579

Search for package or bug name: Reporting problems