CVE-2017-11406

NameCVE-2017-11406
DescriptionIn Wireshark 2.2.0 to 2.2.7 and 2.0.0 to 2.0.13, the DOCSIS dissector could go into an infinite loop. This was addressed in plugins/docsis/packet-docsis.c by rejecting invalid Frame Control parameter values.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs870172

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)jessie1.12.1+g01b65bf-4+deb8u11vulnerable
jessie (security)1.12.1+g01b65bf-4+deb8u14vulnerable
stretch2.2.6+g32dac6a-2+deb9u2vulnerable
stretch (security)2.2.6+g32dac6a-2+deb9u3vulnerable
buster, sid2.4.6-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)2.4.0-1high870172

Notes

[stretch] - wireshark <no-dsa> (Minor issue)
[jessie] - wireshark <no-dsa> (Minor issue)
[wheezy] - wireshark <no-dsa> (Minor issue)
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=13797
https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=250216263c3a3f2c651e80d9c6b3dc0adc53dc2c
https://www.wireshark.org/security/wnpa-sec-2017-36.html

Search for package or bug name: Reporting problems