CVE-2017-11409

NameCVE-2017-11409
DescriptionIn Wireshark 2.0.0 to 2.0.13, the GPRS LLC dissector could go into a large loop. This was addressed in epan/dissectors/packet-gprs-llc.c by using a different integer data type.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)wheezy1.8.2-5wheezy18vulnerable
wheezy (security)1.12.1+g01b65bf-4+deb8u6~deb7u7vulnerable
jessie (security), jessie1.12.1+g01b65bf-4+deb8u11vulnerable
stretch2.2.6+g32dac6a-2fixed
buster, sid2.4.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)2.2.0~rc1+g438c022-1high

Notes

https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=13603
https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=57b83bbbd76f543eb8d108919f13b662910bff9a
https://www.wireshark.org/security/wnpa-sec-2017-37.html
Technically the 2.2.0~rc1+g438c022-1 is just the first version in unstable
after 2.1.0 from upstream. Upstream changed the types in llc_gprs_dissect_xid
in version 2.1.0.

Search for package or bug name: Reporting problems