CVE-2017-11411

NameCVE-2017-11411
DescriptionIn Wireshark through 2.0.13 and 2.2.x through 2.2.7, the openSAFETY dissector could crash or exhaust system memory. This was addressed in epan/dissectors/packet-opensafety.c by adding length validation. NOTE: this vulnerability exists because of an incomplete fix for CVE-2017-9350.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs870179

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)jessie1.12.1+g01b65bf-4+deb8u14fixed
jessie (security)1.12.1+g01b65bf-4+deb8u15fixed
stretch (security), stretch2.6.3-1~deb9u1fixed
buster, sid2.6.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)2.4.0-1high870179
wiresharksourcejessie(not affected)
wiresharksourcestretch(not affected)
wiresharksourcewheezy(not affected)

Notes

[stretch] - wireshark <not-affected> (Incomplete fix for CVE-2017-9350 not applied)
[jessie] - wireshark <not-affected> (Incomplete fix for CVE-2017-9350 not applied)
[wheezy] - wireshark <not-affected> (Incomplete fix for CVE-2017-9350 not applied)
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=13755
https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=a83a324acdfc07a0ca8b65e6ebaba3374ab19c76
https://www.wireshark.org/security/wnpa-sec-2017-28.html

Search for package or bug name: Reporting problems