CVE-2017-11542

NameCVE-2017-11542
Descriptiontcpdump 4.9.0 has a heap-based buffer over-read in the pimv1_print function in print-pim.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tcpdump (PTS)wheezy4.3.0-1+deb7u2vulnerable
wheezy (security)4.9.0-1~deb7u1vulnerable
jessie (security), jessie4.9.0-1~deb8u1vulnerable
stretch4.9.0-2vulnerable
buster, sid4.9.0-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tcpdumpsource(unstable)(unfixed)high

Notes

https://github.com/hackerlib/hackerlib-vul/tree/master/tcpdump-vul/heap-buffer-overflow/print-pim

Search for package or bug name: Reporting problems