DescriptionThere is a Mismatched Memory Management Routines vulnerability in the Exiv2::FileIo::seek function of Exiv2 0.26 that will lead to a remote denial of service attack (heap memory corruption) via crafted input.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
exiv2 (PTS)wheezy0.23-1fixed
wheezy (security)0.23-1+deb7u2fixed
buster, sid, stretch0.25-3.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
exiv2source(unstable)(not affected)


- exiv2 <not-affected> (printTiffStructure introduced in 0.26)
Report against experimental
Not reproducible in wheezy/jessie/stretch/sid(0.25-3.1).
Reproducible in experimental with version 0.26-1.

Search for package or bug name: Reporting problems