CVE-2017-11610

NameCVE-2017-11610
DescriptionThe XML-RPC server in supervisor before 3.0.1, 3.1.x before 3.1.4, 3.2.x before 3.2.4, and 3.3.x before 3.3.3 allows remote authenticated users to execute arbitrary commands via a crafted XML-RPC request, related to nested supervisord namespace lookups.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1047-1, DSA-3942-1
NVD severityhigh (attack range: remote)
Debian Bugs870187

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
supervisor (PTS)wheezy3.0a8-1.1+deb7u1vulnerable
wheezy (security)3.0a8-1.1+deb7u2fixed
jessie (security), jessie3.0r1-1+deb8u1fixed
stretch (security), stretch3.3.1-1+deb9u1fixed
buster, sid3.3.1-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
supervisorsource(unstable)3.3.1-1.1high870187
supervisorsourcejessie3.0r1-1+deb8u1highDSA-3942-1
supervisorsourcestretch3.3.1-1+deb9u1highDSA-3942-1
supervisorsourcewheezy3.0a8-1.1+deb7u2highDLA-1047-1

Notes

https://github.com/Supervisor/supervisor/issues/964
3.3.3 https://github.com/Supervisor/supervisor/commit/058f46141e346b18dee0497ba11203cb81ecb19e
3.2.4 https://github.com/Supervisor/supervisor/commit/aac3c21893cab7361f5c35c8e20341b298f6462e
3.1.4 https://github.com/Supervisor/supervisor/commit/dbe0f55871a122eac75760aef511efc3a8830b88
3.0.1 https://github.com/Supervisor/supervisor/commit/83060f3383ebd26add094398174f1de34cf7b7f0

Search for package or bug name: Reporting problems