CVE-2017-11753

NameCVE-2017-11753
DescriptionThe GetImageDepth function in MagickCore/attribute.c in ImageMagick 7.0.6-4 might allow remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted Flexible Image Transport System (FITS) file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)wheezy8:6.7.7.10-5+deb7u4fixed
wheezy (security)8:6.7.7.10-5+deb7u21fixed
jessie (security), jessie8:6.8.9.9-5+deb8u11fixed
stretch8:6.9.7.4+dfsg-11+deb9u3fixed
stretch (security)8:6.9.7.4+dfsg-11+deb9u4fixed
buster8:6.9.9.34+dfsg-3fixed
sid8:6.9.9.39+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksource(unstable)(not affected)

Notes

- imagemagick <not-affected> (Affects only ImageMagick-7; vulnerable code not present)
https://github.com/ImageMagick/ImageMagick/issues/629

Search for package or bug name: Reporting problems