CVE-2017-12065

NameCVE-2017-12065
Descriptionspikekill.php in Cacti before 1.1.16 might allow remote attackers to execute arbitrary code via the avgnan, outlier-start, or outlier-end parameter.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs870353

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cacti (PTS)stretch (security), stretch0.8.8h+ds1-10+deb9u1fixed
buster1.2.2+ds1-2+deb10u4fixed
buster (security)1.2.2+ds1-2+deb10u2fixed
bullseye, sid1.2.16+ds1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cactisourcewheezy(not affected)
cactisourcejessie(not affected)
cactisourcestretch(not affected)
cactisource(unstable)1.1.16+ds1-1870353

Notes

[stretch] - cacti <not-affected> (Vulnerable code introduced later)
[jessie] - cacti <not-affected> (Vulnerable code introduced later)
[wheezy] - cacti <not-affected> (Vulnerable code introduced later)
https://github.com/Cacti/cacti/commit/bd0e586f6f46d814930226f1516a194e7e72293e
https://github.com/Cacti/cacti/issues/877

Search for package or bug name: Reporting problems