CVE-2017-12151

NameCVE-2017-12151
DescriptionA flaw was found in the way samba client before samba 4.4.16, samba 4.5.14 and samba 4.6.8 used encryption with the max protocol set as SMB3. The connection could lose the requirement for signing and encrypting to any DFS redirects, allowing an attacker to read or alter the contents of the connection via a man-in-the-middle attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3983-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
samba (PTS)jessie (security), jessie2:4.2.14+dfsg-0+deb8u9fixed
stretch2:4.5.12+dfsg-2+deb9u2fixed
stretch (security)2:4.5.12+dfsg-2+deb9u3fixed
buster, sid2:4.8.2+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sambasource(unstable)2:4.6.7+dfsg-2
sambasourcejessie2:4.2.14+dfsg-0+deb8u8DSA-3983-1
sambasourcestretch2:4.5.8+dfsg-2+deb9u2DSA-3983-1
sambasourcewheezy(not affected)

Notes

[wheezy] - samba <not-affected> (Vulnerable code introduced later)
https://www.samba.org/samba/security/CVE-2017-12151.html

Search for package or bug name: Reporting problems